DocumentGetPaintedMaterial Method |
Get the material painted on the element's face. Returns invalidElementId if the face is not painted.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementId GetPaintedMaterial(
ElementId elementId,
Face face
)
Public Function GetPaintedMaterial (
elementId As ElementId,
face As Face
) As ElementId
public:
ElementId^ GetPaintedMaterial(
ElementId^ elementId,
Face^ face
)
member GetPaintedMaterial :
elementId : ElementId *
face : Face -> ElementId
Parameters
- elementId ElementId
-
The element that the face belongs to.
- face Face
-
The painted element's face.
Return Value
ElementId
The material's Id painted on the element's face.
Exceptions
See Also