ParameterSet Class

A set that contains parameters.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBParameterSet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ParameterSet : APIObject, 
	IEnumerable

The ParameterSet type exposes the following members.

Constructors
 NameDescription
Public methodParameterSetInitializes a new instance of the ParameterSet class
Top
Properties
 NameDescription
Public propertyIsEmptyTest to see if the set is empty.
Public propertySizeReturns the number of parameters that are in the set.
Top
Methods
 NameDescription
Public methodClearRemoves every parameter from the set, rendering it empty.
Public methodContainsTests for the existence of a parameter within the set.
Public methodEraseRemoves a specified parameter from the set.
Public methodForwardIteratorRetrieve a forward moving iterator to the set.
Public methodGetEnumeratorRetrieve a forward moving iterator to the set.
Public methodInsertInsert the specified parameter into the set.
Public methodReverseIteratorRetrieve a backward moving iterator to the set.
Top
See Also