NonContinuousRailStructureIsValidNonContinuousRailProfile Method |
Checks whether the input id represents a profile which can be used as the profile of this non-continuous rail.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsValidNonContinuousRailProfile(
ElementId profileId
)
Public Function IsValidNonContinuousRailProfile (
profileId As ElementId
) As Boolean
public:
bool IsValidNonContinuousRailProfile(
ElementId^ profileId
)
member IsValidNonContinuousRailProfile :
profileId : ElementId -> bool
Parameters
- profileId ElementId
-
The profile Id to be checked.
Return Value
Boolean
True if the ElementId refers to a valid NonContinuousRail profile, false otherwise.
Exceptions
RemarksInvalidElementId is considered a valid NonContinuousRail profile (the default profile).
See Also