StructuralConnectionHandlerTypeCreate(Document, String, Guid, String, ElementId) Method |
Creates a new StructuralConnectionHandlerType object.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static StructuralConnectionHandlerType Create(
Document pADoc,
string name,
Guid guid,
string familyName,
ElementId categoryId
)
Public Shared Function Create (
pADoc As Document,
name As String,
guid As Guid,
familyName As String,
categoryId As ElementId
) As StructuralConnectionHandlerType
public:
static StructuralConnectionHandlerType^ Create(
Document^ pADoc,
String^ name,
Guid guid,
String^ familyName,
ElementId^ categoryId
)
static member Create :
pADoc : Document *
name : string *
guid : Guid *
familyName : string *
categoryId : ElementId -> StructuralConnectionHandlerType
Parameters
- pADoc Document
-
The document.
- name String
-
The type name.
- guid Guid
-
Connection GUID.
- familyName String
-
Name of system family which created type will belong to.
- categoryId ElementId
-
Category identity of connection type.
Return Value
StructuralConnectionHandlerType
The newly created instance.
Exceptions
See Also