ValueAtPointBase Class

A base class representing storage of values at a given point.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ValueAtPointBase : IDisposable

The ValueAtPointBase type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodClearAllFlags Sets flags for all measurements to ValueAtPointFlags::None.
Public methodClearFlagsAt Sets flags for the given measurement to ValueAtPointFlags::None.
Public methodDisposeReleases all resources used by the ValueAtPointBase
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetFlags Returns flags for the given measurement.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodSetFlags(IListInt32) Independently sets the flags associated to all measurements.
Public methodSetFlags(Int32) Sets the flags associated to all measurements to the same value.
Public methodSetFlags(Int32, Int32) Sets the flags associated to a given measurement.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
This class stores a set of measurements and corresponding mapped flags. The flags are defined in the enumerated type ValueAtPointFlags.
See Also