RebarCurvesDataAddBarGeometry(IListCurve) Method |
Adds a new bar to the new rebar geometry. This information is set to the rebar after the API execution is finished successfully.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic RebarFreeFormValidationResult AddBarGeometry(
IList<Curve> curves
)
Public Function AddBarGeometry (
curves As IList(Of Curve)
) As RebarFreeFormValidationResult
public:
RebarFreeFormValidationResult AddBarGeometry(
IList<Curve^>^ curves
)
member AddBarGeometry :
curves : IList<Curve> -> RebarFreeFormValidationResult
Parameters
- curves IListCurve
-
Curves describing one bar in the set.
Return Value
RebarFreeFormValidationResult
Returns Success if everything is ok, otherwise the failure reason.
Exceptions
RemarksThis function will can fail due to following reasons:
- One or more of the input curves was null.
- One or more of the input curves was unbounded.
- Curves doesn't form a valid curve loop, it forms 0, 2 or more curve loops.
- A rebar constructed from curves can't be bent according to the bending radius.
See Also