RebarFreeFormValidationResult Enumeration |
Errors for the Free Form Rebar
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum RebarFreeFormValidationResult
Public Enumeration RebarFreeFormValidationResult
public enum class RebarFreeFormValidationResult
type RebarFreeFormValidationResult
MembersMember name | Value | Description |
---|
Success | 0 |
Operation was done with success.
|
Undefined | 1 |
An unexpected error occured.
|
NullCurve | 2 |
One or more of the input curves was null.
|
UnboundCurve | 3 |
One or more of the input curves was unbounded.
|
InvalidLoop | 4 |
Curves doesn't form a valid curve loop.
|
RebarCantBeBent | 5 |
A rebar constructed from curves can't be bent according to the bending radius.
|
See Also