EdgeAsCurveFollowingFace Method

Returns a curve that corresponds to this edge as oriented in its topological direction on the specified face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Curve AsCurveFollowingFace(
	Face faceForDir
)

Parameters

faceForDir  Face
Specifies the face, on which the curve will follow the topological direction of the edge.

Return Value

Curve
It can be an Arc, Line, or HermiteSpline.
Exceptions
ExceptionCondition
ArgumentNullException Thrown when the specified faceForDir is .
ArgumentException Thrown when the specified faceForDir is not one of the faces for this edge.
Remarks
Evaluating the edge using EvaluateOnFace gives the same result as evaluating the curve returned by AsCurveFollowingFace with a normalized curve parameter. When a Hermite spline is returned, the two evaluated points will be approximately equal.
See Also