ElementPhaseStatusFilter(ElementId, ElementOnPhaseStatus, Boolean) Constructor

Constructs a new instance of a file to match elements that have a given phase status on the input phase, with the option to match all elements that have a phase status other than the input status.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementPhaseStatusFilter(
	ElementId phaseId,
	ElementOnPhaseStatus phaseStatus,
	bool inverted
)

Parameters

phaseId  ElementId
Id of the phase.
phaseStatus  ElementOnPhaseStatus
Target status.
inverted  Boolean
True to match all phase statuses other than the input status.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also