SketchedStairsCurveData Constructor |
Construct a SketchedStairsCurveData defined by a curve associated with its height and slope type.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic SketchedStairsCurveData(
Curve boundaryCurve,
double height,
SketchedCurveSlopeOption slopeType
)
Public Sub New (
boundaryCurve As Curve,
height As Double,
slopeType As SketchedCurveSlopeOption
)
public:
SketchedStairsCurveData(
Curve^ boundaryCurve,
double height,
SketchedCurveSlopeOption slopeType
)
new :
boundaryCurve : Curve *
height : float *
slopeType : SketchedCurveSlopeOption -> SketchedStairsCurveData
Parameters
- boundaryCurve Curve
-
- height Double
-
- slopeType SketchedCurveSlopeOption
-
Exceptions
See Also