RibbonPanelAddStackedItems(RibbonItemData, RibbonItemData, RibbonItemData) Method |
Adds three stacked items to the panel.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<RibbonItem> AddStackedItems(
RibbonItemData item1,
RibbonItemData item2,
RibbonItemData item3
)
Public Function AddStackedItems (
item1 As RibbonItemData,
item2 As RibbonItemData,
item3 As RibbonItemData
) As IList(Of RibbonItem)
public:
IList<RibbonItem^>^ AddStackedItems(
RibbonItemData^ item1,
RibbonItemData^ item2,
RibbonItemData^ item3
)
member AddStackedItems :
item1 : RibbonItemData *
item2 : RibbonItemData *
item3 : RibbonItemData -> IList<RibbonItem>
Parameters
- item1 RibbonItemData
- Data containing information about the first item. This data must be of type PushButtonData, PulldownButtonData, SplitButtonData, ComboBoxData, or TextBoxData.
- item2 RibbonItemData
- Data containing information about the second item. This data must be of type PushButtonData, PulldownButtonData, SplitButtonData, ComboBoxData, or TextBoxData.
- item3 RibbonItemData
- Data containing information about the third item. This data must be of type PushButtonData, PulldownButtonData, SplitButtonData, ComboBoxData, or TextBoxData.
Return Value
IListRibbonItem A collection containing the added items.
ExceptionsException | Condition |
---|
ArgumentNullException | Thrown when item1, item2 or item3 is . |
ArgumentException | Thrown when an item with item1.Name or item2.Name or item3.Name already exists in the panel or the data is not of the correct type. |
Remarks Each new item may either be a PushButton, PulldownButton, SplitButton, ComboBox or TextBox, depending upon the type of
data passed in for each argument. The new items will be created as small-size horizontal controls,
with the first stacked on top of the second in the panel.
See Also