FabricationPartTypeLookup Method |
Looks up an existing fabrication part type based on a specfic fabrication service button and condition.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static ElementId Lookup(
Document document,
FabricationServiceButton button,
int condition
)
Public Shared Function Lookup (
document As Document,
button As FabricationServiceButton,
condition As Integer
) As ElementId
public:
static ElementId^ Lookup(
Document^ document,
FabricationServiceButton^ button,
int condition
)
static member Lookup :
document : Document *
button : FabricationServiceButton *
condition : int -> ElementId
Parameters
- document Document
-
The document.
- button FabricationServiceButton
-
The fabrication service button.
- condition Int32
-
The condition index.
Return Value
ElementId
Identifier of the fabrication part type element or invalidElementId if no fabrication part type exist for the
specific fabrication service button and condition
Exceptions
See Also