BuiltInFailuresSlabShapeFailures Class

Failures about SlabShape.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBBuiltInFailuresSlabShapeFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class SlabShapeFailures

The BuiltInFailuresSlabShapeFailures type exposes the following members.

Properties
 NameDescription
Public propertyStatic memberSlabShapeEditFailed Slab Shape Edit failed. [Description]
Public propertyStatic memberSlabShapeEditFailedError Slab Shape Edit failed. [Description]
Public propertyStatic memberSlabShapeFailedNotHorz The Floor or Roof or Toposolid is no longer horizontal.
Public propertyStatic memberSlabShapeFailedNotOnlyLines The Floor or Roof or Toposolid may only contain straight lines.
Public propertyStatic memberSlabShapeFailedTooThin The Floor or Roof or Toposolid is too thin for its given type.
Public propertyStatic memberSlabShapeWarnVerticesCoincident Some slab shape edit vertices were too close to each other or too close to an edge.
Public propertyStatic memberSlabShapeWarnVerticesDeleted Some slab shape edit vertices were deleted because the Floor or Roof or Toposolid has changed its shape.
Public propertyStatic memberSlopedInnerEdge Inner loops of a footprint sketch may not have slope-defining lines.
Public propertyStatic memberSlopeTailInsideSlopeLine The tails of slope arrows must not lie in interior of slope defining lines.
Public propertyStatic memberSlopeZero Adjusting this Line's Overhang will not affect its height because its slope is zero.
Top
See Also