StructuralSectionUtilsSetStructuralSection Method |
Set structural section in element.
Namespace: Autodesk.Revit.DB.Structure.StructuralSectionsAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool SetStructuralSection(
Document document,
ElementId familySymbolId,
StructuralSection structuralSection
)
Public Shared Function SetStructuralSection (
document As Document,
familySymbolId As ElementId,
structuralSection As StructuralSection
) As Boolean
public:
static bool SetStructuralSection(
Document^ document,
ElementId^ familySymbolId,
StructuralSection^ structuralSection
)
static member SetStructuralSection :
document : Document *
familySymbolId : ElementId *
structuralSection : StructuralSection -> bool
Parameters
- document Document
-
The document that owns the family for beam, brace or structural column.
- familySymbolId ElementId
-
ID of family symbol for beam, brace or structural column.
- structuralSection StructuralSection
-
Structural section with values that will be set.
Return Value
Boolean
True is returned when requested shape with values was properly set. Return false otherwise.
Exceptions
Remarks
Only beams, braces and structural columns can have structural section associated with it.
See Also