PreviewFamilyVisibilityMode Enumeration |
Modes that control visibility of family elements depending on
the currently applied Element Visibility Settings of a view.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum PreviewFamilyVisibilityMode
Public Enumeration PreviewFamilyVisibilityMode
public enum class PreviewFamilyVisibilityMode
type PreviewFamilyVisibilityMode
MembersMember name | Value | Description |
---|
Off | 0 |
Element Visibility is not applied. All family elements visible.
|
On | 1 |
Element Visibility of a view is applied to show visible elements only.
Elements that are cut by a reference plane will be shown with their respective cut geometry.
|
Uncut | 2 |
Element Visibility of a view is applied to show elements visible if instance is not cut.
Note that this state is only available in certain views, such as floor plan and ceilings.
|
Remarks
Values of this mode can be set or obtained for any view that supports it by accessing
the [!:Autodesk::Revit::DB::TemporaryViewModes::PreviewFamilyVisibility]
property.
See Also