DocumentNewSpaces2(Phase, Int32) Method |
Creates a set of new unplaced spaces on a given phase.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ICollection<ElementId> NewSpaces2(
Phase phase,
int count
)
Public Function NewSpaces2 (
phase As Phase,
count As Integer
) As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ NewSpaces2(
Phase^ phase,
int count
)
member NewSpaces2 :
phase : Phase *
count : int -> ICollection<ElementId>
Parameters
- phase Phase
- The phase in which the spaces are to exist.
- count Int32
-
Return Value
ICollectionElementId If successful, a set of ElementIds of new unplaced spaces are be returned, otherwise
.
ExceptionsException | Condition |
---|
ArgumentException | Thrown if the phase does not exist in the given document. |
See Also