RebarSpliceOptions Constructor |
Constructs a RebarSpliceOptions
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic RebarSpliceOptions(
Document document,
ElementId spliceTypeId,
RebarSplicePosition splicePosition
)
Public Sub New (
document As Document,
spliceTypeId As ElementId,
splicePosition As RebarSplicePosition
)
public:
RebarSpliceOptions(
Document^ document,
ElementId^ spliceTypeId,
RebarSplicePosition splicePosition
)
new :
document : Document *
spliceTypeId : ElementId *
splicePosition : RebarSplicePosition -> RebarSpliceOptions
Parameters
- document Document
-
The document.
- spliceTypeId ElementId
-
The splice type id.
- splicePosition RebarSplicePosition
-
The splice line position.
ExceptionsException | Condition |
---|
ArgumentException |
The provided spliceTypeId is not a Rebar Splice Type id. It should be an ElementType of BuiltInCategory.OST_RebarSpliceType category.
|
ArgumentNullException |
A non-optional argument was null
|
ArgumentOutOfRangeException |
A value passed for an enumeration argument is not a member of that enumeration
|
See Also