RebarSplicePosition Enumeration |
Describes the position of the splice.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum RebarSplicePosition
Public Enumeration RebarSplicePosition
public enum class RebarSplicePosition
MembersMember name | Value | Description |
---|
End1 | 0 |
Lap is towards the start of the splice chain.
|
Middle | 1 |
Lap goes into both directions.
|
End2 | 2 |
Lap is towards the end of the splice chain.
|
Remarks
This class describes the position of the splice face with respect to each bar end involved in splice.
Middle describes the behavior when both bar ends extends with half of the lap length and the splice plane sits between them.
End1 and End2 describes the behavior when one of the bar ends is on the splice plane and the other bar end extends with the lap length.
End1 means that the lap is computed towards the start of the splice chain, while End2 means that the lap is computed towards the end of the splice chain.
A splice chain represents an array of spliced rebars ordered by constraints (second is constrained to first, third to second and so on).
See Also