RebarShapeConstraint180DegreeBendRadius Constructor |
Create a 180-degree bend constraint driven by radius.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic RebarShapeConstraint180DegreeBendRadius(
ElementId paramId,
RebarShapeArcReferenceType refType
)
Public Sub New (
paramId As ElementId,
refType As RebarShapeArcReferenceType
)
public:
RebarShapeConstraint180DegreeBendRadius(
ElementId^ paramId,
RebarShapeArcReferenceType refType
)
new :
paramId : ElementId *
refType : RebarShapeArcReferenceType -> RebarShapeConstraint180DegreeBendRadius
Parameters
- paramId ElementId
-
The Id of a Rebar Shape parameter.
- refType RebarShapeArcReferenceType
-
A choice of rule for measuring the radius.
Exceptions
See Also