RebarCouplerCreate Method |
Creates a new instance of a Rebar Coupler element within the project.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static RebarCoupler Create(
Document doc,
ElementId typeId,
ReinforcementData pFirstData,
ReinforcementData pSecondData,
out RebarCouplerError error
)
Public Shared Function Create (
doc As Document,
typeId As ElementId,
pFirstData As ReinforcementData,
pSecondData As ReinforcementData,
<OutAttribute> ByRef error As RebarCouplerError
) As RebarCoupler
public:
static RebarCoupler^ Create(
Document^ doc,
ElementId^ typeId,
ReinforcementData^ pFirstData,
ReinforcementData^ pSecondData,
[OutAttribute] RebarCouplerError% error
)
static member Create :
doc : Document *
typeId : ElementId *
pFirstData : ReinforcementData *
pSecondData : ReinforcementData *
error : RebarCouplerError byref -> RebarCoupler
Parameters
- doc Document
-
A document.
- typeId ElementId
-
type id for coupler
- pFirstData ReinforcementData
-
information about the first reinforcement to be coupled
- pSecondData ReinforcementData
-
information about the second reinforcement to be coupled;
if a nullptr is passed in the coupler is placed on one reinforcement
- error RebarCouplerError
-
will be ValidationSuccesfully(0) if ok, otherwise the failure reason
Return Value
RebarCoupler
The newly created Rebar Coupler instance, or
if the operation fails.
Exceptions
See Also