RebarCouplerError Enumeration

Error states for the Rebar Coupler

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public enum RebarCouplerError
Members
Member nameValueDescription
ValidationSuccessfuly0 Bars can be coupled
IncorrectInputData1 Cannot place rebar coupler.
DifferentLayout2 The rebar sets have different numbers of bars.
BarsNotTouching3 The selected ends of the bars are too far apart.
IncorrectEndTreatmentHook4 The coupler cannot be placed at an end that already has a hook.
IncorrectEndTreatmentCoupler5 The coupler cannot be placed at an end that already has a coupler.
BarSegementsAreNotParallel6 The selected legs are not aligned.
BarSegmentsAreNotOnSameLine7 The selected legs are not aligned.
InconsistentShape8 One of the selected bars has an incorrect shape.
InvalidDiameter9 The selected coupler type cannot be applied to the selected bar size(s).
CurvesOtherThanLine12 Cannot place rebar couplers on circular legs.
BarSegmentSmallerThanEngagement13 The selected leg is shorter than the bar engagement.
VaryingDistanceBetweenDistributionsBars14 All the bars from the selected sets, which need to be connected, must be separated by the same distance.
ArcsHaveDifferentRadii15 Cannot place rebar couplers on arcs with different radii.
ArcsHaveDifferentCenters16 Cannot place rebar couplers on arcs with different centers.
ArcToStraightSegment17 Cannot connect by coupler a straight segment with an arc segment.
BendingPlanesAreNotParallel18 The bending planes of the connected bars are not parallel. This will be returned when connecting two shape-driven rebars whose bending planes are not parallel and the bar curves that need to be connected are not aligned.
See Also