DefinitionBindingMap Class

A map that contains mappings of parameter definitions to parameter bindings.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBDefinitionBindingMap
      Autodesk.Revit.DBBindingMap

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DefinitionBindingMap : APIObject, 
	IEnumerable

The DefinitionBindingMap type exposes the following members.

Constructors
 NameDescription
Public methodDefinitionBindingMapInitializes a new instance of the DefinitionBindingMap class
Top
Properties
 NameDescription
Public propertyIsEmptyTest to see if the map is empty.
Public propertyCode exampleIsReadOnlyIdentifies if the object is read-only or modifiable.
(Inherited from APIObject)
Public propertyItem 
Public propertySizeReturns the number of bindings that are in the map.
Top
Methods
 NameDescription
Public methodClearRemoves every binding from the map, rendering it empty.
Public methodContains 
Public methodDisposeCauses the object to release immediately any resources it may be utilizing.
(Inherited from APIObject)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodErase 
Public methodForwardIteratorRetrieve a forward moving iterator to the map.
Public methodGetEnumeratorRetrieve a forward moving iterator to the map.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodInsert 
Public methodReverseIteratorRetrieve a backward moving iterator to the map.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also