DocumentLink(String, DWFImportOptions) Method |
Links Markups in a DWF file into the project document.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<ElementId> Link(
string file,
DWFImportOptions options
)
Public Function Link (
file As String,
options As DWFImportOptions
) As IList(Of ElementId)
public:
IList<ElementId^>^ Link(
String^ file,
DWFImportOptions^ options
)
member Link :
file : string *
options : DWFImportOptions -> IList<ElementId>
Parameters
- file String
-
Full path of the file to link. File must exist and must be a valid DWF file.
- options DWFImportOptions
-
Various link options applicable to the DWF format.
Return Value
IListElementId
A collection of link instance element ids created by the markup link.
Exceptions
Remarks
Link isn't supported for family documents. Please use import instead.
See Also