This interface represents a selected set of views/sheets which will be used for printing.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic interface IViewSheetSet
Public Interface IViewSheetSet
public interface class IViewSheetSet
type IViewSheetSet = interface end
The IViewSheetSet type exposes the following members.
Properties
Exampleprivate void SwitchToAutomaticOrder(Document doc, ViewSheetSetting viewSheetSetting)
{
IViewSheetSet viewSheetSet = viewSheetSetting.CurrentViewSheetSet;
var sheetBrowserOrg = BrowserOrganization.GetCurrentBrowserOrganizationForSheets(doc);
var viewBrowserOrg = BrowserOrganization.GetCurrentBrowserOrganizationForViews(doc);
viewSheetSet.SheetOrganizationId = sheetBrowserOrg.Id;
viewSheetSet.ViewOrganizationId = viewBrowserOrg.Id;
viewSheetSet.IsAutomatic = true;
}
private void SwitchToCustomOrder(Document doc, ViewSheetSetting viewSheetSetting, IReadOnlyList<View> customViews)
{
IViewSheetSet viewSheetSet = viewSheetSetting.CurrentViewSheetSet;
viewSheetSet.IsAutomatic = false;
viewSheetSet.OrderedViewList = customViews;
}
Private Sub SwitchToAutomaticOrder(ByVal doc As Document, ByVal viewSheetSetting As ViewSheetSetting)
Dim viewSheetSet = viewSheetSetting.CurrentViewSheetSet
Dim sheetBrowserOrg = BrowserOrganization.GetCurrentBrowserOrganizationForSheets(doc)
Dim viewBrowserOrg = BrowserOrganization.GetCurrentBrowserOrganizationForViews(doc)
viewSheetSet.SheetOrganizationId = sheetBrowserOrg.Id
viewSheetSet.ViewOrganizationId = viewBrowserOrg.Id
viewSheetSet.IsAutomatic = True
End Sub
Private Sub SwitchToCustomOrder(ByVal doc As Document, ByVal viewSheetSetting As ViewSheetSetting, ByVal customViews As IReadOnlyList(Of View))
Dim viewSheetSet = viewSheetSetting.CurrentViewSheetSet
viewSheetSet.IsAutomatic = False
viewSheetSet.OrderedViewList = customViews
End Sub
No code example is currently available or this language may not be supported.
No code example is currently available or this language may not be supported.
See Also