RebarSpliceUtilsGetLapDirectionForSpliceGeometryAndPosition Method |
This function calculates the lap direction given a RebarSpliceGeometry and a RebarSplicePosition.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static XYZ GetLapDirectionForSpliceGeometryAndPosition(
Rebar rebar,
RebarSpliceGeometry spliceGeometry,
RebarSplicePosition splicePosition
)
Public Shared Function GetLapDirectionForSpliceGeometryAndPosition (
rebar As Rebar,
spliceGeometry As RebarSpliceGeometry,
splicePosition As RebarSplicePosition
) As XYZ
public:
static XYZ^ GetLapDirectionForSpliceGeometryAndPosition(
Rebar^ rebar,
RebarSpliceGeometry^ spliceGeometry,
RebarSplicePosition splicePosition
)
static member GetLapDirectionForSpliceGeometryAndPosition :
rebar : Rebar *
spliceGeometry : RebarSpliceGeometry *
splicePosition : RebarSplicePosition -> XYZ
Parameters
- rebar Rebar
-
The input rebar.
- spliceGeometry RebarSpliceGeometry
-
The splice geometry.
- splicePosition RebarSplicePosition
-
The splice position.
Return Value
XYZ
The lap direction.
Exceptions
Remarks
This function determines first the point where the RebarSpliceGeometry will cut the rebar.
Based on the RebarSplicePosition value it will determine the direction where the lap will go, RebarSplicePosition.End1 meaning towards the start of the splice chain and RebarSplicePosition.End2 towards the end.
For more information about the splice chain concept please check Autodesk.Revit.DB.Structure.RebarSpliceUtils.GetSpliceChain(Rebar rebar).
This function will throw exception if it's called with RebarSplicePosition.Middle.
See Also