SketchEditScopeIsSketchEditingSupportedForSketchBasedElement Method

Checks whether the element supports sketch editing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsSketchEditingSupportedForSketchBasedElement(
	ElementId elemId
)

Parameters

elemId  ElementId
The element id to be checked.

Return Value

Boolean
True if element supports sketch editing, false otherwise.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
Remarks
This method checks if the element supports edit to all its sketches. If you want to check if this element supports edit to a particular sketch please use IsSketchEditingSupported(ElementId).
See Also