SketchEditScopeIsSketchEditingSupported Method

Checks whether sketch can be edited.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsSketchEditingSupported(
	ElementId sketchId
)

Parameters

sketchId  ElementId
The element id of sketch.

Return Value

Boolean
True if sketch can be edited, false otherwise.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
Remarks
This method checks if this particular sketch can be edited. If you want to check if all sketches of an element can be edited please use IsSketchEditingSupportedForSketchBasedElement(ElementId)
See Also