WallCreate(Document, Curve, ElementId, Boolean) Method |
Creates a new rectangular profile wall within the project using the default wall style.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static Wall Create(
Document document,
Curve curve,
ElementId levelId,
bool structural
)
Public Shared Function Create (
document As Document,
curve As Curve,
levelId As ElementId,
structural As Boolean
) As Wall
public:
static Wall^ Create(
Document^ document,
Curve^ curve,
ElementId^ levelId,
bool structural
)
static member Create :
document : Document *
curve : Curve *
levelId : ElementId *
structural : bool -> Wall
Parameters
- document Document
-
The document in which the new wall is created.
- curve Curve
-
A curve representing the base line of the wall.
- levelId ElementId
-
Id of the level on which the wall is to be placed.
- structural Boolean
-
If set, specifies that the wall is structural in nature.
Return Value
Wall
If successful a new wall object within the project.
Exceptions
Examplepublic Wall CreateWallUsingCurve1(Autodesk.Revit.DB.Document document, Level level)
{
XYZ start = new XYZ(0, 0, 0);
XYZ end = new XYZ(10, 10, 0);
Line geomLine = Line.CreateBound(start, end);
return Wall.Create(document, geomLine, level.Id, true);
}
Public Function CreateWallUsingCurve1(document As Autodesk.Revit.DB.Document, level As Level) As Wall
Dim start As New XYZ(0, 0, 0)
Dim [end] As New XYZ(10, 10, 0)
Dim geomLine As Line = Line.CreateBound(start, [end])
Return Wall.Create(document, geomLine, level.Id, True)
End Function
No code example is currently available or this language may not be supported.
No code example is currently available or this language may not be supported.
See Also