MultistoryStairsDisconnectLevels Method |
Shrinks the multistory stairs by disconnecting input levels.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void DisconnectLevels(
ISet<ElementId> levelIds
)
Public Sub DisconnectLevels (
levelIds As ISet(Of ElementId)
)
public:
void DisconnectLevels(
ISet<ElementId^>^ levelIds
)
member DisconnectLevels :
levelIds : ISet<ElementId> -> unit
Parameters
- levelIds ISetElementId
-
The level ids.
Exceptions
Remarks
If you remove a stairs that is connected at the top and bottom to another level stairs, the remaining stairs will automatically adjust to maintain the multistory stairs.
The stairs above the one that is removed extends to attach to the stairs on the level below the one that is removed.
You cannot disconnect the levels of standard stair (the stair associated with the Reference Level for the multistory stairs) or already disconnected.
See Also