RebarFreeFormAccessorSetCurves(IListIListCurve) Method |
Set the curves into a free form Rebar. Will throw exception if the rebar has valid constraints.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic RebarFreeFormValidationResult SetCurves(
IList<IList<Curve>> curves
)
Public Function SetCurves (
curves As IList(Of IList(Of Curve))
) As RebarFreeFormValidationResult
public:
RebarFreeFormValidationResult SetCurves(
IList<IList<Curve^>^>^ curves
)
member SetCurves :
curves : IList<IList<Curve>> -> RebarFreeFormValidationResult
Parameters
- curves IListIListCurve
-
Each array of curves represent a bar in the set.
Return Value
RebarFreeFormValidationResult
Returns Success(0) if everything is ok, otherwise the failure reason.
Exceptions
RemarksThis function can fail due to following reasons:
- One or more of the input curves was null.
- One or more of the input curves was unbounded.
- Curves doesn't form a valid curve loop, it forms 0, 2 or more curve loops.
- A rebar constructed from curves can't be bent according to the bending radius.
See Also