RailingSetMultistoryStairsPlacementLevels Method

Sets the ids of the base levels of the stairs upon which this railing is placed.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetMultistoryStairsPlacementLevels(
	ISet<ElementId> levelIds
)

Parameters

levelIds  ISetElementId
The ids of levels the railing is placed on. If input level id set is empty, railings will placed on all levels of the hosting stairs.
Exceptions
ExceptionCondition
ArgumentException All of the level ids in levelIds must be placement levels of stairs.
ArgumentNullException A non-optional argument was null
InvalidOperationException The railing is not hosted by stairs in MultistoryStairs.
Remarks
The method is valid only for railings hosted by stairs in MultistoryStairs. The input level ids have to be a subset of level ids of the railing stairs. See MultistoryStairs for information about the placement levels that may be passed as input.
See Also