MultiReferenceAnnotationIs3DViewValidForDimension Method |
If the DimensionStyle is LinearFixed, it cannot be created in a 3D View.
If the DimensionStyle is Linear, it cannot be created in a 3D View if the view direction is perpendicular to the current work plane normal.
Returns true if the ownerViewId is not a 3D view.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool Is3DViewValidForDimension(
Document document,
ElementId ownerViewId,
MultiReferenceAnnotationOptions options
)
Public Shared Function Is3DViewValidForDimension (
document As Document,
ownerViewId As ElementId,
options As MultiReferenceAnnotationOptions
) As Boolean
public:
static bool Is3DViewValidForDimension(
Document^ document,
ElementId^ ownerViewId,
MultiReferenceAnnotationOptions^ options
)
static member Is3DViewValidForDimension :
document : Document *
ownerViewId : ElementId *
options : MultiReferenceAnnotationOptions -> bool
Parameters
- document Document
-
The document for the multi-reference annotation.
- ownerViewId ElementId
-
The view in which the multi-reference annotation will appear.
- options MultiReferenceAnnotationOptions
-
Options containing the references which the dimension will witness.
Return Value
Boolean
True if the view is suitable for placing the MultiReferenceAnnotation.
False otherwise.
Exceptions
See Also