DocumentNewSpace(Level, UV) Method

Creates a new space element on the given level at the given location.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Space NewSpace(
	Level level,
	UV point
)

Parameters

level  Level
The level on which the space is to exist.
point  UV
A 2D point that dictates the location on that specified level.

Return Value

Space
If successful the new space element is returned, otherwise .
Exceptions
ExceptionCondition
ArgumentNullException Thrown when level or point is .
InvalidOperationException Thrown when the space cannot be created.
ArgumentExceptionThrown if the level does not exist in the given document.
See Also