MultiReferenceAnnotationAreReferencesValidForLinearDimension Method |
If the DimensionStyleType is Linear, validates that the references are valid
for an aligned multi-reference annotation.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool AreReferencesValidForLinearDimension(
Document document,
ElementId ownerViewId,
MultiReferenceAnnotationOptions options
)
Public Shared Function AreReferencesValidForLinearDimension (
document As Document,
ownerViewId As ElementId,
options As MultiReferenceAnnotationOptions
) As Boolean
public:
static bool AreReferencesValidForLinearDimension(
Document^ document,
ElementId^ ownerViewId,
MultiReferenceAnnotationOptions^ options
)
static member AreReferencesValidForLinearDimension :
document : Document *
ownerViewId : ElementId *
options : MultiReferenceAnnotationOptions -> bool
Parameters
- document Document
-
The document for the multi-reference annotation.
- ownerViewId ElementId
-
The view in which the multi-reference annotation will appear.
- options MultiReferenceAnnotationOptions
-
Options containing the references which the dimension will witness.
Return Value
Boolean
True DimensionStyleType does not equal Linear or
if an aligned multi-reference annotation can be created from the references.
Exceptions
See Also