ViewDisplayDepthCueing Class

Represents the settings for depth cueing.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBViewDisplayDepthCueing

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ViewDisplayDepthCueing : IDisposable

The ViewDisplayDepthCueing type exposes the following members.

Properties
 NameDescription
Public propertyEnableDepthCueing True to enable depth cueing. False to disable it.
Public propertyEndPercentage The end percentage defines where depth cueing ends. Values between 0 and 100.
Public propertyFadeTo The fade to defines the maximum fading in per cent. Values between 0 and 100.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyStartPercentage The start percentage defines where depth cueing starts. Values between 0 and 100.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the ViewDisplayDepthCueing
Public methodSetStartEndPercentages Sets start and end percentages.
Top
Example
private void AdjustDepthCueing(View view)
{
    if (view.CanUseDepthCueing())
    {
        using (Transaction t = new Transaction(view.Document, "Change depth cueing"))
        {
            t.Start();
            ViewDisplayDepthCueing depthCueing = view.GetDepthCueing();
            depthCueing.EnableDepthCueing = true;
            depthCueing.FadeTo = 50;    // set fade to percent
            depthCueing.SetStartEndPercentages(0, 75);
            view.SetDepthCueing(depthCueing);
            t.Commit();
        }
    }
}
See Also