ExporterIFCGetHostObjects Method |
Returns a collection containing the host object handles in the document.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<IDictionary<ElementId, IFCAnyHandle>> GetHostObjects()
Public Function GetHostObjects As IList(Of IDictionary(Of ElementId, IFCAnyHandle))
public:
IList<IDictionary<ElementId^, IFCAnyHandle^>^>^ GetHostObjects()
member GetHostObjects : unit -> IList<IDictionary<ElementId, IFCAnyHandle>>
Return Value
IListIDictionaryElementId,
IFCAnyHandle
The collection of host objects.
Remarks
Host object handles is currently collected by RegisterSpaceBoundingElementHandle
and exporting internal element and cached in the ExporterIFC object.
This method returns the cached information which is needed to create wall connectivity objects.
See Also