DocumentGetTypeOfStorage Method |
Get the storage type of the identified built-in parameter.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic StorageType GetTypeOfStorage(
ForgeTypeId parameterTypeId
)
Public Function GetTypeOfStorage (
parameterTypeId As ForgeTypeId
) As StorageType
public:
StorageType GetTypeOfStorage(
ForgeTypeId^ parameterTypeId
)
member GetTypeOfStorage :
parameterTypeId : ForgeTypeId -> StorageType
Parameters
- parameterTypeId ForgeTypeId
- Identifier of the built-in parameter.
Return Value
StorageTypeStorage type of the built-in parameter.
ExceptionsException | Condition |
---|
ArgumentException |
parameterTypeId does not identify a built-in parameter. See Parameter.IsBuiltInParameter(ForgeTypeId) and Parameter.GetParameterTypeId(BuiltInParameter).
|
ArgumentNullException |
A non-optional argument was NULL
|
See Also