An enumerated type listing all of the internal parameter data storage types that Autodesk Revit supports.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
SyntaxPublic Enumeration StorageType
public enum class StorageType
MembersMember name | Value | Description |
---|
None | 0 |
None represents an invalid storage type. This value should not be used.
|
Integer | 1 |
The internal data is stored in the form of a signed 32 bit integer.
|
Double | 2 |
The data will be stored internally in the form of an 8 byte floating point number.
|
String | 3 |
The internal data will be stored in the form of a string of characters.
|
ElementId | 4 |
The data type represents an element and is stored as the id of the element.
|
See Also