BuiltInFailuresImportFailures Class

Failures about ImportFailures.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBBuiltInFailuresImportFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class ImportFailures

The BuiltInFailuresImportFailures type exposes the following members.

Properties
 NameDescription
Public propertyStatic memberATFContainedUnsupportedGeometricData The original model contains unsupported geometric data.
Public propertyStatic memberATFNonUniformScalingTransform The imported geometry contains non-uniform scaling transformations which Revit does not support. Some objects may be displaced or distorted.
Public propertyStatic memberBadFaceFoundInDwg One or more hatch regions were found in the imported file with unconnected boundaries. These hatch regions will be ignored.
Public propertyStatic memberCannotChangeImportSymbol Can't change an imported or linked element's symbol type.
Public propertyStatic memberCannotExplodeElement Can't explode the imported object.
Public propertyStatic memberCannotImportFile Can't import file.
Public propertyStatic memberElementRenamedOnImport There were duplicate names between the active model and the imported element. To avoid duplicate names, the imported element has been renamed.
Public propertyStatic memberFailedToSetWorkplane Could not set Work Plane of [Import].\n\nPlease use the Work Plane tool to set a Work Plane for this view.
Public propertyStatic memberIFCCantUpdateLinkedFile The cached version of this IFC file is already loaded into another document in this session, and can't be updated. To update the IFC file, please close all other documents containing the link, and then update.
Public propertyStatic memberIFCGenericImportWarning The following problems were encountered in the IFC file: [Description]
Public propertyStatic memberIFCGenericRevitImportWarning Revit had the following problems importing the IFC file: [Description]
Public propertyStatic memberIFCPartialSchemaSupport IFC versions 4 and above are only partially supported by Open IFC. Consider using Link IFC instead.
Public propertyStatic memberImportedModelIsEmpty Imported model is empty.
Public propertyStatic memberImportedModelWithDifferentLengthUnits The imported model uses different length units, Revit will default to auto-detect.
Public propertyStatic memberImportModelOutOfRange The imported model is out of range.
Public propertyStatic memberImportModelTooLarge The imported model is too large.
Public propertyStatic memberImportScaleTooLarge This scale factor would make the imported object too large. Reverting to the previous scale factor.
Public propertyStatic memberImportSymbolBaseLevelInvalid 
Public propertyStatic memberImportTooFarAway Imported objects located a large distance from the model might not display properly. The 'Center-to-Center' option will be used.
Public propertyStatic memberImportTooManyElmentsToExplode Import Instance has [Number] elements. Imports with more than 10,000 elements cannot be exploded.
Public propertyStatic memberLevelRenamedOnImport This level has been renamed from [SourceLevelName] to avoid duplication.
Public propertyStatic memberLostAcisObjectsOnImport Some ACIS objects could not be imported. To import them, use AutoCAD to convert them into polymesh objects and reimport.
Public propertyStatic memberSomeObjectsNotExploded Import contained some 3D data or points which can't be exploded.
Public propertyStatic memberTextNotImported Text is only imported if the "Current View Only" option is selected. To see the text in the original file, import again with this check box selected in the Import Dialog.
Public propertyStatic memberTooManyPickFaces Too many faces were created from imported meshes. Host by Face tools may not select the imported meshes correctly. Decrease the complexity of the file or try importing only selected layers to resolve.
Public propertyStatic memberViewDoesNotSupportCenterToCenter The "Center to Center" option is not supported by this view because it is empty. "Origin to Internal Origin" has been used instead.
Public propertyStatic memberWorksetCreatedForLinkWarning Newly created link types and instances were placed in new workset [workset name]
Top
See Also