WireSizeSetIterator Class

An iterator to a wire size set.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DB.ElectricalWireSizeSetIterator

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public abstract class WireSizeSetIterator : APIObject, 
	IEnumerator

The WireSizeSetIterator type exposes the following members.

Constructors
 NameDescription
Public methodWireSizeSetIteratorFor Internal Use Only.
Top
Properties
 NameDescription
Public propertyCurrentRetrieves the item that is the current focus of the iterator.
Top
Methods
 NameDescription
Public methodMoveNextMove the iterator one item forward.
Public methodResetBring the iterator back to the start of the set.
Top
See Also