FileExportingEventArgs Class

The event arguments used by the FileExporting event.
Inheritance Hierarchy
SystemObject
  SystemEventArgs
    Autodesk.Revit.DB.EventsRevitAPIEventArgs
      Autodesk.Revit.DB.EventsRevitAPIPreEventArgs
        Autodesk.Revit.DB.EventsRevitAPIPreDocEventArgs
          Autodesk.Revit.DB.EventsFileExportingEventArgs

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FileExportingEventArgs : RevitAPIPreDocEventArgs

The FileExportingEventArgs type exposes the following members.

Properties
 NameDescription
Public propertyBackgroundOperation Identifies whether the event belongs to a background export operation.
Public propertyFormat Identifies the export format, e.g. DWG or image.
Public propertyPath The target path for the export.
Top
Methods
 NameDescription
Top
See Also