BuiltInFailuresJoinElementsFailures Class

Failures about JoinElements.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBBuiltInFailuresJoinElementsFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class JoinElementsFailures

The BuiltInFailuresJoinElementsFailures type exposes the following members.

Properties
 NameDescription
Public propertyStatic memberCannotCope Can't apply Coping.
Public propertyStatic memberCannotCutJoinedGeometry Element could not be cut by joined element.
Public propertyStatic memberCannotJoinDesignOptions An element cannot join to an element in a secondary Design Option unless it is in the same secondary Design Option.
Public propertyStatic memberCannotJoinElements Can't keep elements joined.
Public propertyStatic memberCannotJoinElementsError Can't keep elements joined.
Public propertyStatic memberCannotJoinElementsMultiPlaneError Can't keep elements joined.
Public propertyStatic memberCannotJoinElementsStructural Can't keep elements joined.
Public propertyStatic memberCannotJoinElementsStructuralError Can't keep elements joined.
Public propertyStatic memberCannotJoinElementsWarn Can't keep elements joined.
Public propertyStatic memberCannotJoinRoof The roof cannot be joined.
Public propertyStatic memberCannotJoinRoofError The roof cannot be joined.
Public propertyStatic memberCannotKeepJoined Can't keep elements joined.
Public propertyStatic memberCannotKeepReferenceOfJoinedElement Can't keep reference of joined element.
Public propertyStatic memberCannotKeepReferenceOfJoinedElementWarning Can't keep reference of joined element.
Public propertyStatic memberCannotKeepTrussJoined Can't keep the highlighted [Element]s joined.
Public propertyStatic memberCannotKeepWallJoinToRoof Can't keep wall and [target] joined
Public propertyStatic memberCannotKeepWallJoinToRoofError Can't keep wall and [target] joined
Public propertyStatic memberElementWillBeDetachedFromPlane Element will be detached from its associated plane
Public propertyStatic memberFootingWillMoveToBottom An attached Structural Foundation will be moved to the bottom of the Column.
Public propertyStatic memberJoiningDisjoint Highlighted elements are joined but do not intersect.
Public propertyStatic memberJoiningDisjointWarn Highlighted elements are joined but do not intersect.
Public propertyStatic memberStairsComponentTypeUnsupportedError The selected stair type/shape isn't supported for attaching a wall to a stair. To continue, detach the wall from the stairs' components.
Public propertyStatic memberStructGroupMemberWillDetachFromGrid A structural element will be detached from grid(s) due to inconsistent group membership.
Public propertyStatic memberWallTypeUnsupportedError The selected wall type/shape isn't supported for attaching a wall to a stair. To continue, detach the wall from the stairs' components.
Top
See Also