UpdaterRegistryAddTrigger(UpdaterId, Document, ICollectionElementId, ChangeType) Method |
Adds a trigger to an updater with specified set of elements and ChangeType
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static void AddTrigger(
UpdaterId id,
Document document,
ICollection<ElementId> elements,
ChangeType change
)
Public Shared Sub AddTrigger (
id As UpdaterId,
document As Document,
elements As ICollection(Of ElementId),
change As ChangeType
)
public:
static void AddTrigger(
UpdaterId^ id,
Document^ document,
ICollection<ElementId^>^ elements,
ChangeType^ change
)
static member AddTrigger :
id : UpdaterId *
document : Document *
elements : ICollection<ElementId> *
change : ChangeType -> unit
Parameters
- id UpdaterId
-
Id of updater that trigger should be added to
- document Document
-
Document that elements in 'elements' are contained in
- elements ICollectionElementId
-
Set of elements which define this trigger
- change ChangeType
-
ChangeType associated with this trigger
ExceptionsException | Condition |
---|
ArgumentNullException |
A non-optional argument was null
|
InvalidOperationException |
updater's owner AddIn does not match the currently active AddIn
-or-
id does not correspond to any registered Updaters
-or-
AddTrigger called while executing an updater.
|
See Also