Determine if this Outline intersects the input Outline to within a specified tolerance.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool Intersects(
Outline outline,
double tolerance
)
Public Function Intersects (
outline As Outline,
tolerance As Double
) As Boolean
public:
bool Intersects(
Outline^ outline,
double tolerance
)
member Intersects :
outline : Outline *
tolerance : float -> bool
Parameters
- outline Outline
-
The outline to test for intersection with this one.
- tolerance Double
-
The tolerance to use when determining intersection. Defaults to zero.
Return Value
Boolean
True if the given outline intersects this outline.
Exceptions
Remarks
If the tolerance is positive, the outlines may be separated by the tolerance distance in each coordinate.
If the tolerance is negative, the outlines must overlap by at least the tolerance distance in each coordinate.
See Also