Determine if this Outline intersects the input Outline to within a specified tolerance.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public bool Intersects( Outline outline, double tolerance ) |
Visual Basic |
---|
Public Function Intersects ( _ outline As Outline, _ tolerance As Double _ ) As Boolean |
Visual C++ |
---|
public: bool Intersects( Outline^ outline, double tolerance ) |
Parameters
- outline
- Type: Autodesk.Revit.DB..::..Outline
The outline to test for intersection with this one.
- tolerance
- Type: System..::..Double
The tolerance to use when determining intersection. Defaults to zero.
Return Value
True if the given outline intersects this outline.
Remarks
If the tolerance is positive, the outlines may be separated by the tolerance distance in each coordinate.
If the tolerance is negative, the outlines must overlap by at least the tolerance distance in each coordinate.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |