ExternalServiceId Class

Unique identifier of an external service.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBGuidEnum
    Autodesk.Revit.DB.ExternalServiceExternalServiceId

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ExternalServiceId : GuidEnum

The ExternalServiceId type exposes the following members.

Constructors
 NameDescription
Public methodExternalServiceIdCreates a new ExternalServiceId instance.
Top
Properties
 NameDescription
Public propertyGuid The Guid of GUID-based enum object.
(Inherited from GuidEnum)
Top
Methods
 NameDescription
Public methodEquals Compares two Guid-based enum object based on their concrete class and GUID value.
(Inherited from GuidEnum)
Public methodGetHashCode Generates a hash code for this Guid-based enum object.
(Inherited from GuidEnum)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Operators
 NameDescription
Public operatorStatic memberEquality(ExternalServiceId, ExternalServiceId)Compares two ExternalServiceId instances.
Public operatorStatic memberInequality(ExternalServiceId, ExternalServiceId)Compares two ExternalServiceId instances.
Top
Remarks
Each external service must have a unique ExternalServiceId. The Id can be registered with Revit for servers to easily find it. Unique ExternalServiceId should be created using GUID generation tool. ExternalServiceId can later be used to access registered external services.
See Also