UIView Class

A class containing data about view windows in the Revit user interface.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.UIUIView

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class UIView : IDisposable

The UIView type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyViewId The id of the View associated with a UIView.
Top
Methods
 NameDescription
Public methodClose Closes the view.
Public methodDisposeReleases all resources used by the UIView
Public methodGetWindowRectangle Gets the rectangle containing the coordinates of the view's drawing area.
Public methodGetZoomCorners Gets the corners of the view's rectangle. The two points that define the corners of the view's rectangle in model coordinates.
Public methodZoom Zoom the view.
Public methodZoomAndCenterRectangle Zoom and center the view to a specified rectangle.
Public methodZoomSheetSize Zoom to the sheet size.
Public methodZoomToFit Zoom the view to fit its contents.
Top
See Also