ElementPhaseStatusFilter(ElementId, ElementOnPhaseStatus) Constructor |
Constructs a new instance of a file to match elements that have a given phase status on the input phase.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementPhaseStatusFilter(
ElementId phaseId,
ElementOnPhaseStatus phaseStatus
)
Public Sub New (
phaseId As ElementId,
phaseStatus As ElementOnPhaseStatus
)
public:
ElementPhaseStatusFilter(
ElementId^ phaseId,
ElementOnPhaseStatus phaseStatus
)
new :
phaseId : ElementId *
phaseStatus : ElementOnPhaseStatus -> ElementPhaseStatusFilter
Parameters
- phaseId ElementId
-
Id of the phase.
- phaseStatus ElementOnPhaseStatus
-
Target status.
Exceptions
See Also