RebarShapeConstraintAngleFromFixedDir Constructor |
Create an angular constraint.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic RebarShapeConstraintAngleFromFixedDir(
ElementId paramId,
int sign,
UV direction
)
Public Sub New (
paramId As ElementId,
sign As Integer,
direction As UV
)
public:
RebarShapeConstraintAngleFromFixedDir(
ElementId^ paramId,
int sign,
UV^ direction
)
new :
paramId : ElementId *
sign : int *
direction : UV -> RebarShapeConstraintAngleFromFixedDir
Parameters
- paramId ElementId
-
A Rebar Shape parameter of type UT_Angle.
- sign Int32
-
The sign of the angle relative to the direction.
- direction UV
-
A fixed direction in UV-space.
Exceptions
See Also