IFCExtrusionCalculatorUtilsCalculateExtrusionData(IFCExtrusionCalculatorOptions, GeometryObject) Method

Calculates the extrusion data from a Revit geometry object.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static IList<IFCExtrusionData> CalculateExtrusionData(
	IFCExtrusionCalculatorOptions extrusionOptions,
	GeometryObject geometryObject
)

Parameters

extrusionOptions  IFCExtrusionCalculatorOptions
The options for extrusion extraction.
geometryObject  GeometryObject
The geometry object.

Return Value

IListIFCExtrusionData
A collection of extrusion data calculated for the geometry. If the function fails to calculate one or more valid extrusions, this collection will be empty.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
See Also